Notice
Recent Posts
Recent Comments
Link
일 | 월 | 화 | 수 | 목 | 금 | 토 |
---|---|---|---|---|---|---|
1 | 2 | |||||
3 | 4 | 5 | 6 | 7 | 8 | 9 |
10 | 11 | 12 | 13 | 14 | 15 | 16 |
17 | 18 | 19 | 20 | 21 | 22 | 23 |
24 | 25 | 26 | 27 | 28 | 29 | 30 |
Tags
- 탐욕알고리즘
- 프로그래머스
- 자바
- 리그오브레전드
- java
- git
- 장고
- API
- 알고리즘
- drf
- sort
- programmers
- Riot
- python
- 그리디
- 백준
- lol
- Django
- 롤
- 코딩테스트준비
- github
- 스파르타내일배움캠프
- 그리디알고리즘
- 내일배움캠프
- greedy
- SQL
- 코딩테스트
- 라이엇
- 파이썬
- 스파르타내일배움캠프TIL
Archives
- Today
- Total
Lina's Toolbox
[Greedy] 백준 - 잃어버린 괄호 본문
https://www.acmicpc.net/problem/1541
문제
세준이는 양수와 +, -, 그리고 괄호를 가지고 식을 만들었다. 그리고 나서 세준이는 괄호를 모두 지웠다.
그리고 나서 세준이는 괄호를 적절히 쳐서 이 식의 값을 최소로 만들려고 한다.
괄호를 적절히 쳐서 이 식의 값을 최소로 만드는 프로그램을 작성하시오.
입력
첫째 줄에 식이 주어진다. 식은 ‘0’~‘9’, ‘+’, 그리고 ‘-’만으로 이루어져 있고, 가장 처음과 마지막 문자는 숫자이다. 그리고 연속해서 두 개 이상의 연산자가 나타나지 않고, 5자리보다 많이 연속되는 숫자는 없다. 수는 0으로 시작할 수 있다. 입력으로 주어지는 식의 길이는 50보다 작거나 같다.
출력
첫째 줄에 정답을 출력한다.
예제 입력 1
55-50+40
예제 출력1
-35
예제 입력 2
10+20+30+40
예제 출력 2
100
예제 입력 3
00009-00009
예제 출력 3
0
내 풀이
import java.util.*;
public class Main {
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
String expression = sc.nextLine();
int result = 0;
String currentNum = "";
List<Integer> numbers = new ArrayList<>();
List<Character> operators = new ArrayList<>();
for (int i = 0; i < expression.length(); i++) {
char currentChar = expression.charAt(i);
if (Character.isDigit(currentChar)) {
currentNum += currentChar; // 현재 문자가 숫자라면, 문자열에 추가
} else {
numbers.add(Integer.parseInt(currentNum)); // 숫자를 리스트에 추가
currentNum = ""; // 숫자 초기화
operators.add(currentChar); // 연산자 추가
}
}
// 마지막 숫자 추가
numbers.add(Integer.parseInt(currentNum));
// 첫 번째 숫자를 결과로 초기화
result = numbers.get(0);
boolean minusFound = false;
// 연산 수행
for (int i = 1; i < numbers.size(); i++) {
if (i - 1 < operators.size() && operators.get(i - 1) == '-') {
minusFound = true; // 첫 번째 '-' 이후에는 모두 뺄셈
}
if (minusFound) {
result -= numbers.get(i); // '-' 이후는 모두 뺄셈
} else {
result += numbers.get(i); // 그 외는 덧셈
}
}
System.out.println(result);
}
}
다른 풀이
import java.util.*;
public class Main {
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
String expression = sc.nextLine(); // 수식을 입력 받음
String[] minusSplit = expression.split("-"); // '-'를 기준으로 분리
int result = Integer.MAX_VALUE; // 처음엔 임의의 큰 값으로 초기화
for (int i = 0; i < minusSplit.length; i++) {
String part = minusSplit[i]; // '-'로 나뉜 부분들
int sum = 0;
String[] plusSplit = part.split("\\+"); // '+'로 다시 분리
// 각 부분을 더함
for (String num : plusSplit) {
sum += Integer.parseInt(num);
}
// 첫 번째 부분은 그냥 더하고, 나머지는 빼기
if (result == Integer.MAX_VALUE) {
result = sum;
} else {
result -= sum;
}
}
System.out.println(result); // 최종 결과 출력
}
}
'문제 풀이 > 백준' 카테고리의 다른 글
[Greedy] 백준 - 주유소 (1) | 2024.09.27 |
---|---|
[Greedy] 백준 - 동전 0 (1) | 2024.09.26 |
[Greedy] 백준 - ATM (0) | 2024.09.26 |
[Greedy] 백준 - 회의실 배정 (0) | 2024.09.25 |
[Greedy] 백준 - 거스름돈 (0) | 2024.09.24 |